Orchestral Essentials 2

FAQ
What is the difference between Orchestral Essentials 1 and Orchestral Essentials 2?

Orchestral Essentials 1 and Orchestral Essentials 2 are two unique libraries. One does not replace the other, they complement each other. If you own Orchestral Essentials 1, then Orchestral Essentials 2 will offer you 100% new sounds. It will expand your template by adding additional articulations to existing instruments as well as new instruments and ensembles altogether.

 
What is the difference between Orchestral Essentials 1, 2 and the Symphobia series?

The sounds in Orchestral Essentials 2 were selected from other libraries in our catalog, including the Symphobia series. This document shows you the origin of each program found in Orchestral Essentials 2. Each program was streamlined and tweaked to fit into the Orchestral Essentials series concept. If you already own a Symphobia volume, please take a look at this document to see what Orchestral Essentials 2 will add to your template. All instruments in Orchestral Essentials 2 are available in 1 microphone set (close or stage, depending on the instrument). In the original libraries, these instruments are available in multiple microphone sets, a more in-depth interface and, in most cases, more articulations.

 
Do you offer discounts for existing users?

Sorry, we no longer have a loyalty discount program. The first reason is that it became an unmanageable matrix of discounts and combinations. The second reason is that we could not realistically extend the loyalty discount program to our distributors, creating unfair competition. This is why we decided to lower pricing of the Orchestral Essentials series for all users. Please note that we do offer educational discounts.

 
What Kontakt version is required to use Orchestral Essentials 2?

Orchestral Essentials 2 requires Kontakt version 5.4.1 or higher. It cannot be loaded into earlier versions. Orchestral Essentials 2 also works in the free Kontakt Player.

 
Does Orchestral Essentials 2 work with Windows XP or Vista?

No. Orchestral Essentials 2 requires Kontakt 5.4.1, which, in turn, requires Windows 7 or higher.

 
Does Orchestral Essentials 2 work with OS X 10.6 or 10.7?

No. Orchestral Essentials 2 requires Kontakt 5.4.1, which, in turn, requires Mac OS X 10.8 or higher.

 
The Tuba Long program is not making any sound

This was a bug in the initial download version and was fixed a few hours after the library was released. If you were among the very first users to purchase Orchestral Essentials 2 (thank you!) then please download a fixed Tuba Long NKI file here.